Back to overview
Downtime

Main website is down for all users

Apr 29 at 08:32am BST
Affected services
manchesterlads.com

Resolved
Apr 29 at 10:57pm BST

All systems are now functioning correctly.

Updated
Apr 29 at 02:45pm BST

Backups have been restored, and the main functionality of the website has been available for all users since 14.40.

Some ongoing work is required to fix the following:
- affected DNS records (SPF, CNAME)
- admin access*

*It will not be possible to update advertisements until admin access is fully restored.

Created
Apr 29 at 08:32am BST

The server hosting the Manchester Lads website crashed spectacularly late Sunday afternoon, and it is currently offline for all users.

The machine was rebuilt overnight, and an engineer is working to restore files from backups to get everything up and running again.

I don't yet have an ETA for completing this work, but it should be later today. You may monitor the status of the website here: status.manchesterlads.com

Once things are up and running again, I shall credit advertisers for the lost time.

I appreciate your patience while I correct the problem.